Certame N°2 Programación en Java Diurno

Construir una Aplicación Gráfica en Java que permita resolver la siguiente problemática:

Desarrollar Catálogo de Libros ordenados por título.

La funcionalidad de este catálogo es:

  • conocer el número de libros que hay en la lista,
  • insertar un nuevo libro (en la posición que le corresponda),
  • eliminar el libro de una determinada posición
  • y obtener el libro de una determinada posición.

También incluirá un método para buscar un libro a partir de su título (sin distinguir entre mayúsculas y minúsculas); el método devolverá la posición en la que se encuentra el libro (–1 si no se encuentra) y los datos el libro.

Utilice una clase Libro de acuerdo a la siguiente información:

  • título,
  • autor (usa la clase Persona),
  • ISBN,
  • páginas,
  • edición,
  • editorial,
  • lugar (ciudad y país)
  • y fecha de edición (usa la clase Fecha).

La clase debe proporcionar los siguientes servicios:

  • método para leer la información y
  • método para mostrar la información. Este último método mostrará la información del libro con este formato:

Título: Introduction to Java Programming
3a. edición
Autor: Liang, Y. Daniel
ISBN: 0-13-031997-X
Prentice-Hall, New Jersey (USA), viernes 16 de noviembre de
2001
784 páginas

Enviar vía mail a ggonzalez@santotomas.cl durante el día jueves 05 de junio de 2014

Certamen N°2 de Programación en Java Vespertino

A continuación encontrará el Diagrama de Casos de Uso asociado al Caso Práctico del Certame n°2.

caso 6

 

DESARROLLAR UN PROYECTO EN JAVA.

Considere los siguientes Requerimientos:

Se trata de un sistema simplificado de Cajero Automático, que ofrece los siguientes servicios:

  • Distribución de dinero a cada poseedor de una tarjeta inteligente a través de un lector de tarjetas y un distribuidor de efectivo.
  • Consulta del saldo de cuentas, facilidades para depósito de efectivo y cheques para los clientes del banco poseedor de una tarjeta del mismo.

Algunas Consideraciones importantes:

Primero: Existe alguna relación entre PoseedorTarjeta y ClienteBanco?

Segundo: Suponga que, antes de realizar cualquier operación, el usuario debe realizar un login en el sistema. 

Tercero: Sabiendo lo siguiente: “Al final del día, un operario va hasta el cajero a reponer dinero y retirar las tarjetas que fueron retenidas por el mismo.”, ¿Esto forma parte de nuestro sistema?

Cuarto: Descripción del proceso Depositar Efectivo y Depositar Cheque que parecen tener un comportamiento común. 

Depositar Efectivo/Cheque:

1. El usuario indica que quiere depositar dinero(efectivo/cheque),
2. indica el tipo de moneda,
3. indica el monto a depositar,
4. indica el tipo de depósito (efectivo/cheque),
5. realiza el depósito.

Quinto: Suponga que se desea contar con la opción de Consultar Saldo al momento de realizar un Giro. Incluir

Construir una  Interfaz gráfica para el Cajero automático.

FINALMENTE ENVIAR POR CORREO ELECTRÓNICO Al profesor antes las 23:00 horas del día miércoles 04 de junio de 2014.

Práctico de Programación en Java

Oracle-Java

 

Construya un JUEGO CON JAVA:

 

Utilizando el siguiente algoritmo como base.

Juego Adivina_Numero

intentos=9;

num_secreto = azar(100)+1;

Escribir “Adivine el numero (de 1 a 100):”;

Leer num_ingresado;

Mientras num_secreto<>num_ingresado Y intentos>0 Hacer

Si num_secreto>num_ingresado Entonces

Escribir “Muy bajo”;

Sino

Escribir “Muy alto”;

FinSi

Escribir “Le quedan “,intentos,” intentos:”;

Leer num_ingresado;

intentos = intentos-1;

FinMientras

Si intentos=0 Entonces

Escribir “Perdiste!!! El numero era: “,num_secreto;

Sino

Escribir “Exacto! Usted adivino en “,11-intentos,” intentos.”;

FinSi

FinJuego

Se pide programar una solución gráfica que permita ingresar un número y verificar si es el correcto.

Se pide: Enviar proyecto por mail hasta las 14:00 hrs. del día martes 27 de mayo. (ggonzalez@santotomas.cl).

 

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

Únete a otros 808 seguidores

%d personas les gusta esto: